Report processing delayed
Incident Report for Green Bits
Resolved
This incident has been resolved.
Posted over 1 year ago. May 08, 2017 - 06:49 PDT
Identified
We are experiencing some slowness in processing updates to the data that backs our reports. All events are being processed and nothing is lost. We expect this to catch back up in the next several hours.
Posted over 1 year ago. May 07, 2017 - 13:35 PDT