Metrc Packages Transferred Out
Incident Report for Green Bits
Resolved
Inventory adjustments have been made to affected products and all systems affected by this incident are operating normally now. If you made any adjustments to affected packages during this incident, we suggest auditing that inventory from https://secure.greenbits.com/packages as there may be some additional adjustments required.

Thank you for your patience during this frustrating incident. We will be sending out a detailed email to all affected users of what happened and what we are doing to prevent this from happening in the future.
Posted 9 months ago. Jan 26, 2018 - 10:25 PST
Monitoring
All previously affected packages should be marked as active and the distribution of inventory across converted products should be accurate in the Back Office. We will continue to monitor the situation throughout the night.
Posted 9 months ago. Jan 25, 2018 - 18:49 PST
Update
In order to keep ringing sales, we’ve marked any inventory items associated with affected packages as sellable. Please note that while you will be able to sell inventory on hand, the quantities might be inaccurate. To avoid any problems, we suggest disabling “Auto Close Lots” in your Store Settings until this incident is resolved https://secure.greenbits.com/store-options. Please refresh the application in order for this update to take effect on the register.

In the meantime, we are working through all accounts and correcting any inventory discrepancies caused by the issues that happened last night. This work should be done by the end of tonight.

We recognize that this has been a multiday incident and apologize for the stress and confusion this has caused. Thank you for bearing with us.
Posted 9 months ago. Jan 25, 2018 - 13:42 PST
Identified
We have identified more instances of packages being marked as transferred out and are currently reverting all adjustments and transfers that occurred in the past 24 hours. We will notify you as soon as all of those packages have the correct status and quantity and expect these adjustments to happen quickly. We apologize for the impact this had on the store this morning, all hands are on deck getting this work completed at highest priority and all inventory should be sellable shortly.
Posted 9 months ago. Jan 25, 2018 - 10:03 PST
Monitoring
We have identified and are actively resolving all issues that caused this incident. Right now, quantity syncs and the recovery of conversions are still finalizing and we will update this incident as soon as all of that work is completed.
Posted 9 months ago. Jan 24, 2018 - 16:59 PST
Update
At this point, we have identified the remaining tasks our team will complete in order to resolve this incident. Work is still being done on syncing all package quantities and restoring all conversions and is our highest priority. Packages that have been transferred out of your Metrc license are being recognized in Green Bits at a slower rate, but we are actively working on improving that speed.
Posted 9 months ago. Jan 24, 2018 - 13:02 PST
Update
Our engineering team is still making the adjustments and corrections to affected packages and inventory items this morning. We will reach out through this incident status as soon as we see all package quantities in Green Bits corrected to their original quantities.

Our support team does not have more information on when this will be completed, but all proactive reach out to them will receive an update via email as soon as we complete this incident. We apologize for this delay, and it is our team’s highest priority to get these issues addressed ASAP.
Posted 9 months ago. Jan 24, 2018 - 10:29 PST
Update
Our engineers are currently going through all affected locations to correct any discrepancies that came up on inventory items during the work done today. We appreciate your patience as we finalize this process, all package quantities should match Metrc when this work is completed.
Posted 9 months ago. Jan 23, 2018 - 19:41 PST
Update
Our engineering team has deployed the fix for the transferred out packages and we are currently seeing packages flowing back into active inventory and we are restoring any previous conversions to the proper inventory levels. This work should be completed by this afternoon, and we will post here when the work is 100% completed.
Posted 9 months ago. Jan 23, 2018 - 10:52 PST
Update
Thank you for your patience and apologies for the delay and impact this has had on your store. Our team is seeing that some of the work to reopen packages that were transferred out of your inventory in Green Bits didn't fully complete overnight. We have received multiple reports of packages still affected and are investigating.

Our engineering team is all hands on deck working together to get the fixes for the root cause of this issue implemented ASAP. At that time, the two conditions mentioned in the update last night will be resolved. We expect this to be resolved today, but will be posting status updates immediately when we see resolution to this incident here.
Posted 9 months ago. Jan 23, 2018 - 09:24 PST
Update
Over the past few hours, our engineers have marked the majority of affected packages as no longer transferred out in the Green Bits back office. The engineering team just kicked off one last script that will be working over the next few hours to mark all of the remaining affected packages as no longer transferred out.

In order for us to complete this work, there are two side effects that you should be aware of.

1) Some packages that were correctly marked as transferred out in Green Bits were toggled to active in Green Bits erroneously. This is due to the lack of an API response that allows us to accurately confirm which packages are active/inactive currently. If you come across one of these inventory items or packages, we advise to mark those inventory items as unsellable to prevent incorrect sales.

2) We have had to temporarily disable our feature that automatically recognizes and marks packages as transferred out in Green Bits until we complete the work with Metrc to adapt to the unannounced API changes that caused this incident this morning at 1am PT.

As soon as point 2 has been addressed, we will notify you through this incident, and any incorrectly activated packages in Green Bits will automatically be recognized as transferred out. Thank you again for your patience through this incident, we know that this had a big impact at your stores and will notify you as soon as we have more information or an ETA with resolution for the above points.
Posted 9 months ago. Jan 22, 2018 - 17:47 PST
Update
We are beginning to see some packages showing up with their corrected quantity, but there are still several incorrectly marked as transferred out. Thank you for your patience thus far.

We identified an unexpected API change in Metrc that went out this morning at approximately 1AM PT which caused the initial "transferring out" of these packages. Our engineering team is rolling out a fix as soon as possible and we will keep you updated when that update is fully deployed.
Posted 9 months ago. Jan 22, 2018 - 13:46 PST
Identified
Early this morning, there was an incident that incorrectly marked packages in some Metrc stores as transferred out. We have engineers actively investigating what caused this issue. We are also working on reverting the incorrect adjustments en masse for affected stores and transferred out tags so that you can get those packages back on the floor. We apologize for the inconvenience and will notify you as soon as we have submitted those adjustments.
Posted 9 months ago. Jan 22, 2018 - 10:42 PST