WA Traceability Connection Issues
Incident Report for Green Bits
Resolved
BioTrack servers are back online and accessible. All orders are preserved and will be reported shortly. Thank you for your patience.
Posted over 1 year ago. Jul 01, 2017 - 11:51 PDT
Monitoring
We are again experiencing issues connecting with the WA Traceability System. Biotrack's servers are currently unreachable. We will be monitoring the issue until their servers are available. Sorry for the inconvenience this is causing.
Posted over 1 year ago. Jul 01, 2017 - 11:26 PDT