Slow loading pages
Incident Report for Green Bits
Resolved
This incident has been resolved.
Posted Feb 13, 2019 - 16:49 PST
Investigating
Our site is currently experiencing a higher than usual amount of load. The higher load may be causing some pages to be slow or unresponsive for some users. This should not affect your ability to make sales at the register. We are investigating the cause.
Posted Feb 13, 2019 - 16:32 PST
This incident affected: Back Office.