1/10 Slow Report Generation
Incident Report for Green Bits
Resolved
This incident has been resolved. Sorry for any inconvenience.
Posted 6 months ago. Jan 10, 2019 - 14:24 PST
Monitoring
Our site is currently experiencing a higher than usual amount of load. The higher load may be causing some pages to be slow or unresponsive. We have deployed a fix and are monitoring the issue.

Expect an additional update at 2:30 PM Pacific.
Posted 6 months ago. Jan 10, 2019 - 14:18 PST
This incident affected: Green Bits Reporting Service.